How to create an After Effects presets pack compatible with Motion Bro

Structure of an After Effects preset

For an After Effects preset to be correctly added to the timeline, there must be one composition at the project’s root.

If the preset includes any assets, for example, solids, footages, or pre-compositions, place them in a folder named “// Assets“.


Script for splitting an After Effects project into separate presets

If you create a preset pack in a single After Effects project file, you can quickly split it into separate preset files using a script.

View Assets

Structure of an After Effects project for the script to work properly

  1. At the project’s root, create a folders structure with the appropriate category and subcategory names. These folders, except the folders named “// Assets“, will be displayed in the plugin with the same hierarchy.
  2. Place preset compositions in folders with categories and subcategories. Each preset in your project must have a unique name.
  3. If the presets include any assets, for example, solids, footages, or pre-compositions, place them in folder named “// Assets“. When splitting a project, all compositions from that folder will be skipped.
  4. If you have used any assets in your project that should not be stored in presets, such as footage used in previews, move them to a folder named “// FOR DELETE“. The script will delete this folder when splitting presets.

How to split a project into presets using a script?

  1. It is recommended to use a copy of the project for splitting. Go to: File > Save As > Save a Copy.
  2. Run the script. To do this, go to: File > Scripts > Run Script File and select the “Motion Bro AE Pack 1.1.jsx” file on your computer.
  3. In the script panel, select the directory where your preset pack will be located.
  4. Select the mode for splitting presets in the “Split Presets” tab.
  5. Click the “Create Presets” button and wait for the split process to finish.

Preset Options

In the “Preset Options” tab,  you can enable advanced options to have the plugin add presets in a certain way. For more information about the available options, you can check out this page.

Select the required options and click the “Create Setting file” button


Pack Info

In the “Pack Info” tab, you must provide general information about the package.

  1. Specify the name of the package, the name of the author (your nickname or company name), and the package’s version number.
  2. If your package is compatible with the Motion Bro SFX Pack, enable this checkbox.
  3. Click the “Create Pack Info file” button.

 


Render Preview Files

In the “Render Preview Files” tab, you can create previews of your presets. After rendering, the preview files are saved in the directory corresponding to the preset category so that they are displayed correctly in the plugin.

  1. In the “Duration by” section, choose which part of the preset’s composition will be rendered.
  2. In the “Add presets from” section, select which presets will be added to the render queue. Note that the compositions in the “// Assets” folder will not be added to the render queue, as the script will skip it.
  3. Click the “Add to Render Queue” button and wait for the process to complete.

Presets for Output Module

You can use the following types of files as previews:

  • MP4
  • JPG
  • PNG
  • GIF

To quickly set the preview file type in the Render Queue, you must create the appropriate presets for the Output Module. To do this, follow these steps:

  1. Call the context menu in the Output Module and click “Make Template”.
  2. In the settings section, give the preset a name and click the “Edit” button.
  3. In Output Module Settings, set the media file format. For video files, it is recommended to use the H.264 format with a bit rate of 1-2 Mbps. Save the preset by pressing the OK button.
  4. In the Render Queue, select all preset’s compositions (Ctrl + A).
  5. Call the Output Module context menu and select the preset you created. The preset will be added to all selected songs in the queue.
  6. Click the “Render” button and wait for the process to complete.

2 thoughts on “How to create an After Effects presets pack compatible with Motion Bro

Leave a Reply

Your email address will not be published. Required fields are marked *